1117 Eddington Number(25 分)(C++)

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

这题的思想好像某一题中也有体现。

题目大意:找出一个数e,满足该数字串中大于e的数大于等于e个。

思想:从大到小排序后,从最大的数开始遍历,e初始为1,判断e是否还能继续增加,只要判断此时v[i]是否大于e;

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int n, ans, cur;
int main(){
	scanf("%d", &n);
	vector<int>v(n);
	for(int i = 0; i < n; ++ i)
		scanf("%d", &v[i]);
	sort(v.begin(), v.end());
	ans = n;
	while(ans >= 1 && v[n - ans] <= ans)
		-- ans;
	cout << ans;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值