poj 2406 Power Strings【kmp循环节】


Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 50448 Accepted: 21038

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

思路:KMP,next表示模式串如果第i位(设str[0]为第0位)与文本串第j位不匹配则要回到第next[i]位继续与文本串第j位匹配。则模式串第1位到next[n]与模式串第n-next[n]位到n位是匹配的。所以思路和上面一样,如果n%(n-next[n])==0,则存在重复连续子串,长度为n-next[n]。

例如:a    b    a    b    a    b

next:-1   0    0    1    2    3    4

next[n]==4,代表着,前缀abab与后缀abab相等的最长长度,这说明,ab这两个字母为一个循环节,长度=n-next[n];


/* *********************************************** 
┆  ┏┓   ┏┓ ┆ 
┆┏┛┻━━━┛┻┓ ┆ 
┆┃       ┃ ┆ 
┆┃   ━   ┃ ┆ 
┆┃ ┳┛ ┗┳ ┃ ┆ 
┆┃       ┃ ┆ 
┆┃   ┻   ┃ ┆ 
┆┗━┓ 马 ┏━┛ ┆ 
┆  ┃ 勒 ┃  ┆       
┆  ┃ 戈 ┗━━━┓ ┆ 
┆  ┃ 壁     ┣┓┆ 
┆  ┃ 的草泥马  ┏┛┆ 
┆  ┗┓┓┏━┳┓┏┛ ┆ 
┆   ┃┫┫ ┃┫┫ ┆ 
┆   ┗┻┛ ┗┻┛ ┆ 
************************************************ */  
#include<stdio.h>  
#include<string.h>
char S[1000005];
int next[1000005],l;
void GetNext()
{
	int i=0,j=-1;
	next[0]=-1;j=next[i];
	while(i<l)
	{
		if(j==-1||S[i]==S[j])
		{
			next[i+1]=j+1;
			i++; j++;
		}
		else
		{
			j=next[j];
		}
	} 
}
int main()
{
	while( ~scanf("%s",S) )
	{
		if(S[0]=='.')	break;
		l=strlen(S);
		GetNext();
		if(l%(l-next[l])==0)
            printf("%d\n",l/(l-next[l]));
        else
            printf("1\n");
		
	}
	return 0;
} 












评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值