POJ 2406 Power Strings(KMP循环节问题)

题目链接:http://poj.org/problem?id=2406

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

题目大意:给定字符串,求最大循环次数

题目思路:哇,题目描述并没有说遇到.结束输入啊,看了半天没看懂题意==

就是求最大n,即转换为字符串最多循环次数,循环节问题见代码注释

代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
#include<stack>
#include<map>

using namespace std;

#define FOU(i,x,y) for(int i=x;i<=y;i++)
#define FOD(i,x,y) for(int i=x;i>=y;i--)
#define MEM(a,val) memset(a,val,sizeof(a))
#define PI acos(-1.0)

const double EXP = 1e-9;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x3f3f3f3f;
const ll MINF = 0x3f3f3f3f3f3f3f3f;
const int mod = 1e9+7;
const int N = 1e6+5;

char mo[N];
int Next[N];

void Get_next()
{
    int len = strlen(mo);
    int i,j;
    j = Next[0] = -1;
    i = 0;
    while(i<len)
    {
        while(j!=-1&&mo[i]!=mo[j])
            j = Next[j];
        Next[++i] = ++j;
    }
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    std::ios::sync_with_stdio(false);
    while(~scanf(" %s",&mo))
    {
        Get_next();
        int len = strlen(mo);
        if(len == 1 && mo[0]=='.')
            break;
        //循环节问题
        //重要的性质len-next[i]为此字符串的最小循环节(i为字符串的结尾),即循环周期
        //另外如果len%(len-next[i])==0&&len!=(len-next[i]),此字符串的循环次数为len/(len-next[i])的循环串;
        int length = len - Next[len];
        if(len%length==0&&len!=length)
            printf("%d\n",len/length);
        else
            printf("1\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值