the kth number第几大数问题

第几大数问题the kth number

Problem description
Find the kth largest element in an unsorted array A . Note that it is the kth largest element in
the sorted order, not the kth distinct element. The range of length of A is N(1≤N≤5,000,000) and the element (integer) in A is no bigger than 10,000,00000.
问题描述在未排序的数组A中找到第k个最大元素。 请注意,它是排序顺序中第k个最大的元素,而不是第k个不同的元素。 A的长度范围是N(1≤N≤5,000,000),A中的元素(整数)不大于10,000,00000。
Input
Line 1: the length of the unsorted array A and the index k.
Line 2: the all elements in array A and split by spaces
Output
Line 1: A single integer that is the kth largest element in an unsorted array A.
Sample Input 1
8 2
1 3 5 7 4 2 6 8
Sample Output 1
7
Sample Input 2
8 2
1 1 2 2 3 3 4 4
Sample Output 2
4

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;

const int maxn = 5e6 + 10;

int a[maxn];

int main() {
    int n,k; cin >> n >> k;
    for (int i = 0; i < n; i++) scanf("%d",&a[i]);
    sort(a, a + n);
    cout << a[n - k] << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

a soldiers

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值