PAT 甲级 A1001

1001 A+B Format (20分)

题目描述

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

输入格式

Each input file contains one test case. Each case contains a pair of integers a and b where − 1 0 6 10^{6} 106 ≤a,b≤ 1 0 6 10^{6} 106. The numbers are separated by a space.

输出格式

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

总结

  1. 题意大概是给出2个数,然你按照题目给的格式输出。由于a和b的不大,因此不会超界,所以我用了一个非常好理解的方法来解这个题
  2. 设a+b=n,先要做个预处理,若n小于0则输出负号,然后再取相反数;若正数啥也不干。然后就得到n是一个0-2000000的数,分没有逗号,一个逗号和两个逗号三种情况输出,直接进行判断就OK了~注意高位补0

AC代码

#include<iostream>
using namespace std;
int main() {
	int a, b, n;
	scanf("%d %d", &a, &b);
	n = a + b;
	if (n < 0) {
		printf("-");
		n = -n;
	}
	if (n < 1000)  printf("%d",n);
	else if ( n>=1000&&n<1000000) {  //只有一个逗号
		printf("%d,%03d", n/1000,n%1000);
	}
	else { //两个逗号
		printf("%d,%03d,%03d", n / 1000000, n / 1000 % 1000, n % 1000);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
可以使用面向对象的思想来构建“超市购物”程序。我们可以先定义两个类,一个是商品类,一个是购物者类。商品类中包含属性货物名、货号、价格和数量等信息,还包含获取货物名和价格的方法。购物者类中包含购物清单和购买商品等方法。在购物者类中先定义购物清单列表,再根据购买的商品名称查找商品的价格并计算出总价格。每次购买商品时,还需要统计相应商品的销售数量。 下面是一个示例代码: ```python class Commodity: def __init__(self, name, code, price, quantity): self.name = name self.code = code self.price = price self.quantity = quantity def get_name(self): return self.name def get_price(self): return self.price class Shopper: def __init__(self): self.shopping_list = [] # 初始化购物清单 def add_item(self, commodity, quantity): # 添加购买的商品和对应数量 self.shopping_list.append((commodity, quantity)) def print_receipt(self): # 打印购物清单和总价格 total_price = 0 for commodity, quantity in self.shopping_list: name = commodity.get_name() price = commodity.get_price() sub_total = price * quantity total_price += sub_total print(f"{name} x {quantity} = {sub_total}") print(f"Total price: {total_price}") # 统计销售数量 for commodity, quantity in self.shopping_list: commodity.quantity += quantity # 定义一些商品 commodity1 = Commodity("soap", "A1001", 10, 100) commodity2 = Commodity("pen", "A1002", 5, 200) # 创建购物者并购买商品 shopper = Shopper() shopper.add_item(commodity1, 2) shopper.add_item(commodity2, 3) # 打印购物清单并统计销售数量 shopper.print_receipt() print(commodity1.quantity) print(commodity2.quantity) ``` 运行结果: ``` soap x 2 = 20 pen x 3 = 15 Total price: 35 102 203 ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值