PAT 甲级 1016 Phone Bills (25分)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

值得反复去做的一道题,虽然没有什么新的数据结构知识,也不用什么算法,但数据结构的设计和for循环的运用很有难度。

难点:

1.时间怎么处理,输入的时间和不同的用户怎么一一对应,当同一用户有两个不同的通话时间时:给出的数据先按照姓名,后按照时间进行排序,排序后,相同用户不同时间便被排到了相邻的位置
2.对于状态on_line 和off_line,可以降低处理难度的方法是定义一个变量status,和online offline进行对应
3.如何找到相同日期的两个状态,通过排序即可,排序、建立map键值对、利用for循环每次间隔两个作差是这道题的灵魂。
4.假如一个名字对应两条消费记录,怎么去计算费用。建立姓名和通话记录的键值对。通话记录用vector<person>去存放,可以选择的标准是将on_line与off_line状态的消息利用for循环成对装入。

还是太菜了,这一题看着别人的代码几乎一次不差仿照出来的,还得再做。

#include <bits/stdc++.h>
#define maxn 1010

using namespace std;

int t[25];

struct person
{
    string name;
    int m;    //月份
    int d;    //日期
    int h;    //小时
    int mi;   //分
    int status;
    int time_all;  //总时间
};

bool cmp(person p1,person p2)
{
    if(p1.name!=p2.name)
    {
        return p1.name<p2.name;
    }
    else
    {
        return p1.time_all<p2.time_all;      // time_all 越小代表时间越早
    }
}

// 计算费用
double calculate(person p)
{
    double total;
    total  = p.d*t[24]*60;
    for(int i = 0;i<p.h;i++)
    {
        total+=t[i]*60;
    }
    total+=t[p.h]*p.mi;
    total = (total)/100.0;
    return total;
}

int main()
{
    t[24] = 0;
    for(int i = 0;i<24;i++)
    {
        cin>>t[i];
        t[24]+=t[i];
    }
    int k;
    cin>>k;
    vector<person> p(k);       // 存放的是每个账单的信息,长度为k
    for(int i = 0;i<k;i++)
    {
        cin>>p[i].name;
        scanf("%d:%d:%d:%d",&p[i].m,&p[i].d,&p[i].h,&p[i].mi);    // scanf 表示格式化输入
        string sta;
        cin>>sta;
        p[i].status = (sta=="on-line")?1:0;
        p[i].time_all = p[i].mi + p[i].h*60 +p[i].d*24*60;
    }
    sort(p.begin(),p.end(),cmp);
    map<string,vector<person> >m;
    for(int i = 1;i<p.size();i++)
    {
        if(p[i].status==0&&p[i-1].status==1&&p[i].name==p[i-1].name)
        {
            m[p[i-1].name].push_back(p[i-1]);
            m[p[i].name].push_back(p[i]);
        }
    }
    for(map<string,vector<person> >::iterator it=m.begin();it!=m.end();it++)
    {
        cout<<it -> first<<" ";
        vector<person> temp = it ->second;
        printf("%02d\n",temp[1].m);
        double cost = 0.0;
        for(int i = 1;i<temp.size();i+=2)
        {
            printf("%02d:%02d:%02d %02d:%02d:%02d ",temp[i-1].d,temp[i-1].h,temp[i-1].mi,temp[i].d,temp[i].h,temp[i].mi);
            double total1 = calculate(temp[i]);
            double total0 = calculate(temp[i-1]);
            int diff = temp[i].time_all - temp[i-1].time_all;
            cost += (total1 - total0);
            printf("%d $%.2f\n",diff,total1-total0);
        }
        printf("Total amount: $");
        printf("%.2f\n",cost);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值