Just A Triangle

Problem Description

This is an easy problem, just for you to warm up.
Give you three edges of a triangle. Can you tell me which kind of triangle it stands for?
If it’s a right triangle(直角三角形), please output “good”. If it’s a isosceles triangle(等腰三角形), please output “perfect”. Otherwise, please output “just a triangle”. You may suppose the input is legal.

Input
The first line contains an integer t means the number of test cases.
The each case contains three integers a, b, c in a line which stands for the length of the three edges.
(0 <a, b, c < 300).
Output
For each case, output the answer in one line.
Sample Input

4
3 4 5
2 2 3 
1 4 4
4 6 3

Sample Output

good
perfect
perfect
just a triangle 

Code:
思想:判断三角形是什么类型的三角形,条件判断

#include<iostream>
#include<math.h>
using namespace std;
int main() {
	int n,a,b,c,temp;
	while (cin >> n) {
		for (int i = 0; i < n; i++) {
			cin >> a >> b >> c;
			if (a + b <= c || a + c <= b || b + c <= a || a <= 0 || b <= 0 || c <= 0 || a >= 300 || b >= 300 || c >= 300) return 0;
			if (a < b) {
				temp = b;
				b = a;
				a = temp;
			}
			if (a < c) {
				temp = c;
				c = a;
				a = temp;
			}
			if (a == b || b == c||a==c) {
				cout << "perfect" << endl;
			}
			else if (pow(a, 2) == pow(b, 2) + pow(c, 2)) {
				cout << "good" << endl;
			}
			else {
				cout << "just a triangle" << endl;
			}
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值