HDU3188:Just A Triangle

Problem Description
  This is an easy problem, just for you to warm up.
  Give you three edges of a triangle. Can you tell me which kind of triangle it stands for?
If it’s a right triangle(直角三角形), please output “good”. If it’s a isosceles triangle(等腰三角形), please output “perfect”. Otherwise, please output “just a triangle”. You may suppose the input is legal.
 

Input
The first line contains an integer t means the number of test cases.
The each case contains three integers a, b, c in a line which stands for the length of the three edges.
(0 <a, b, c < 300).
 

Output
For each case, output the answer in one line.
 

Sample Input
  
  
4 3 4 5 2 2 3 1 4 4 4 6 3
 

Sample Output
  
  
good perfect perfect just a triangle


 

//简单到无话可说

#include <iostream>
using namespace std;

int main()
{
    int n,a,b,c;
    cin >> n;
    while(n--)
    {
        cin >> a >> b >> c;
        if(a+b > c && a+c > b && b+c > a)
        {
            if(a == b || b == c || a == c)
            cout << "perfect" << endl;
            else
            if(a*a+b*b==c*c || b*b+c*c==a*a || a*a+c*c==b*b )
            cout << "good" << endl;
            else
            cout << "just a triangle" << endl;
        }
    }

    return 0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值