Light Bulb (三分搜索)

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3203

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

 

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000

求人从左向右走动时,影子的长度L的最大值

人在灯下的影子长度是0,这时他如果向前走的话,影子会逐渐变长,到最后人走到墙的位置的时候,影长度便是人的身高了,所以影长的变化曲线要么是单调递增的,要么是向上凸的,所以适合三分。(二分法作为分治中最常见的方法,适用于单调函数,逼近求解某点的值,当函数是凸性函数时,就得用三分)。

由于影长从灯下0一直到恰好没投影到墙上的过程是一个单调的过程,我们可以把这段忽略,直接求解,投影到墙上后,影长的变化即可。

一个double型的三分模板

const double EPS=1e-10;
double calc(double n)
{
    return ;
}
double solve(double L,double R)
{
    double mid,mmid;
    while(L+EPS<R)
    {
        mid=(L+R)/2;
        mmid=(M+R)/2;
        if(calc(mid)<calc(mmid))//计算最小值 最大值改符号
            R=mmid;
        else
            L=mid;
    }
    return L;
}

 

 

 

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
using namespace std;
const double EPS=1e-9;
double H,h,D;
double ff(double n)
{
    return D-n+H-(H-h)*D/n;
}
double f(double L , double R)
{
    double mid,mmid;
    while(R-L>EPS)
    {
        mid=(L+R)/2;
        mmid=(mid+R)/2;
        if(ff(mid)>ff(mmid))
            R=mmid;
        else
            L=mid;
    }
    return ff(mid);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf",&H,&h,&D);
        printf("%.3lf\n",f((H-h)*D/H,D));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值