PAT 甲级 1009 Product of Polynomials

PAT 甲级 1009 Product of Polynomials

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
结尾无空行

Sample Output:

3 3 3.6 2 6.0 1 1.6
结尾无空行
题意描述:

给定两个多项式A和B,求A×B.

解题思路:

模拟题。采用两层嵌套循环模拟两个多项式乘积的计算过程。后面的输出部分就与1002题类似。

难度评测:Normal
AC代码实现:
#include <bits/stdc++.h>
using namespace std;
const int N = 2e3+5;
double a[N], b[N], ans[N];

int main() {
	int k, e, cnt = 0;
	double c;
	cin >> k;
	for(int i = 0; i < k; i++) {
		cin >> e >> c;
		a[e] = c;
	}	
	cin >> k;
	for(int i = 0; i < k; i++) {
		cin >> e >> c;
		b[e] = c;
	}
	for(int i = 1000; i >= 0; i--)
		for(int j = 1000; j >= 0; j--)
			if(a[i] && b[j])
				ans[i + j] += a[i] * b[j];
	for(int i = 2000; i >= 0; i--)
		if(ans[i]) cnt++;
	cout << cnt;
	for(int i = 2000; i >= 0; i--)
		if(ans[i]) printf(" %d %.1f", i, ans[i]);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值