最短路 poj 1052

     Dijkstra:

          基本思想:

          点s到点v路径为m,分别搜索s所连的点(d),以d点为中转点,s->d路径为x0,d->v路径为x1,如若x0+x1<m,则说明s->d点的最短路为x0+x1,这个过程称为松弛。以源点为起点依次寻找中转点,之后中转点更新为源点,继续搜索,直到搜索到点的个数减一(即路径最少为止)。以题为例。

          题目来源:poj    1502

          

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 

``Is there anything you can do to fix that?'' 

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 

``Ah, so you can do the broadcast as a binary tree!'' 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''
Input
The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.
Output
Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.
Sample Input
5
50
30 5
100 20 50
10 x x 10
Sample Output 35 题目大意:输入n表示有n个点,之后有n-1行,分别代表一个邻接矩阵的下半块,其中x表示两点无法到达。输出源点1到达其他点距离的最小值。 解题思路:Dijkstra算法模板,外加字符串处理。 代码:
#include<stdio.h>
#include<string.h>
#include<ctype.h>
int chenge(char s[])
{
	if(s[0]=='x')
	 return -1;
	 int n=0;
	for(int i=0;s[i]!='\0';i++)
	{
		n=n*10+s[i]-'0';
	}
	return n;
}
int main()
{
	int i,j,k,m,n,min,inf,c1;
	int a[110][110];
	int b[110];
	int c[110];
	char s[10];
	inf=99999999;
	while(scanf("%d",&n)!=EOF){
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
		     if(i==j)
		      a[i][j]=0;
		      else
		      a[i][j]=inf;
	    for(i=2;i<=n;i++)
	      for(j=1;j<i;j++)
	       {
	         scanf("%s",s);
			 m=chenge(s);
			 if(m==-1)
			   continue;
			  else
			  {
			    a[i][j]=m;
				a[j][i]=m;
				}	
			}
		for(i=1;i<=n;i++)//以1为源点,用数组记录该源点到其他点的距离。
			c[i]=a[1][i];
		b[1]=1;
		c1=1;       //算法核心
		while(c1<n)
		{
			min=inf;
			for(i=1;i<=n;i++)//寻找和当前点相邻最近的点作为中转点。
			{
				if(min>c[i]&&b[i]==0)
				{
					min=c[i];j=i;
				}
			}
			b[j]=1;
			c1++;
			for(k=1;k<=n;k++)//以中转点遍历其他点,记录源点到其他点的权值和
			{
			   if(a[j][k]<inf)
			   {
			   	  if(b[k]==0&&c[k]>c[j]+a[j][k])//倘若源点到其他点的距离小于源点到中转点与中转点到其他点的和,更新源点到其他点的值
			   	     c[k]=c[j]+a[j][k];
			   }
			}
		}
		min=0;
		for(i=2;i<=n;i++)//数组c中的数字即为源点到达其他点i的最小距离。
		{
			if(min<c[i])
			 min=c[i];
		}
		printf("%d\n",min);
	}
	return 0;
 } 
   
   

       

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值