poj 1050 To the Max

                                                          To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 50008 Accepted: 26501

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 
9 2 -6 2
-4 1 -4 1
-1 8  0 -2

Sample Output

15
题目大意:
给出m*n矩阵,求出其中的最大子矩阵和。
解题思路:
动态规划问题,将矩阵从上而下遍历,将所有子矩阵依次遍历完,用f[i][j][k]来表示矩阵第j列到第k列的和,
之后保留相加和的最大值。其实也可以理解成每次计算每行的第j列到第k列的最大和,再以上一行的结果为基础累加。
代码:
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int a[110][110];
int f[110][110][110];
int main()
{
    int i,j,k,m,n,x,y;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)
          for(j=0;j<n;j++)
            scanf("%d",&a[i][j]);
       memset(f,0,sizeof(f));
       x=-999999999;
       for(i=0;i<n;i++)
       {
          for(j=0;j<n;j++)
          {
              m=0;
              for(k=j;k<n;k++)
              {
                  m+=a[i][k];
                  f[i][j][k]=max(f[i-1][j][k]+m,m);
                  x=max(f[i][j][k],x);
              }
          }
       }
       printf("%d\n",x);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值