poj 1050

由于数据比较小,枚举所有矩形也可以

这里是动态规划,也就是递推每个矩形的值,选出最大的值

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>

using namespace std;
#define INF 0xffff
#define MAX_N 200

int n;
int a[MAX_N][MAX_N];
int dp[MAX_N];
//output
int fun(int b[],int n){
        int maxx,c;
        maxx = -INF;

        for(int i = 0;i < n; i++){
            c = 0;
            for(int j = i;j < n; j++){
                c += b[j];
                maxx = max(c , maxx);
            }
        }
        return maxx;
}
int main(){
       //freopen("in","r",stdin);
        scanf("%d",&n);


        for(int i = 0;i < n; i++){
            for(int j = 0; j < n; j++){
                scanf("%d",&a[i][j]);
            }
        }
   
        int sum = 0;
        int maxx = -INF;
        for(int i = 0;i < n; i++){
            for(int j = i;j < n; j++){

                for(int k = 0;k <= n; k++){
                        dp[k] = dp[k] + a[j][k];
                }

                sum = fun(dp,n);
                maxx = max(maxx, sum);
            }
            memset(dp,0,sizeof(dp));
        }
        
        printf("%d\n",maxx);

    
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值