1148 Werewolf - Simple Version (20 分)

1148 Werewolf - Simple Version (20 分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

player #1 said: “Player #2 is a werewolf.”;
player #2 said: “Player #3 is a human.”;
player #3 said: “Player #4 is a werewolf.”;
player #4 said: “Player #5 is a human.”; and
player #5 said: “Player #4 is a human.”.
Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence – that is, for two sequences A=a[1],…,a[M] and B=b[1],…,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:
5
-2
+3
-4
+5
+4
Sample Output 1:
1 4
Sample Input 2:
6
+6
+3
+1
-5
-2
+4
Sample Output 2 (the solution is not unique):
1 5
Sample Input 3:
5
-2
-3
-4
-5
-1
Sample Output 3:
No Solution

Code

#include<iostream>
#include<algorithm>
#include<fstream>
using namespace std;
int main() {
  int i,j,k,cnt = 0;
  int a[110], b[110] , result[110];
  int liar[5], lie, splie;
  int num;
#ifdef _DEBUG
	ifstream cin("data.txt");
#endif
  cin >> num ;
  for(i = 1; i <= num; i++) {
    int temp;
    cin >> temp;
    if(temp < 0){  b[i] = -1;  a[i] = -temp;}
	
	else{ a[i] = temp; b[i] = 1;}
	
  }
 
    for(int i = 1; i <= num; i++){
      for(j = i + 1; j <= num; j++) {
        for(int m = 1; m <= num; m++) {result[m] = 1; liar[m]=0;}
        result[i] = -1;
        result[j] = -1;
        cnt = lie = splie = 0;
        for(k = 1; k <= num; k++){
          if(b[k] != result[a[k]]){
            if(k == i || k == j){ splie++; liar[cnt++] = k;}
            else { lie++; liar[cnt++] = k;}
          }
        }
        if(lie == 1 && splie == 1) {
          cout << i<< " " << j;
          return 0;
        }
      }
    }
    printf("No Solution");
#ifdef _DEBUG
	cin.close();
#endif
    return 0;
    
  
}

Code2

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e3 + 10;
int a[maxn];
int main(){ 
    int num, i, j; 
    cin >> num; 
    for(i = 1 ; i <= num; i++){  
        cin >> a[i];
    }
    for(i = 1 ; i <= num; i++){  
        for(j = i + 1; j <= num; j++){// i 和j 代表狼 本质上没有顺序的前后
            int  flagwolf = 0, flagcitizen = 0, cnt = 0;// 分别标记是否有狼和民说谎及说谎的人数 
            vector<int> goodorbad(num + 1, 1);
            goodorbad[i] = - 1; goodorbad[j] = - 1;			
            for(int k = 1; k <= num; k++){   // 判断第k个人是否说谎
				int temp1 = a[k], temp2 = goodorbad[abs(a[k])];
                if (temp1 * temp2 < 0){  
                    cnt++;  
                    if((k == i || k == j)){ if(flagwolf == 0 ) flagwolf = 1;}
                    else if(flagcitizen == 0) flagcitizen = 1;   
                } 
            }
            if(cnt == 2 && flagcitizen == 1 && flagwolf == 1){ 
               cout << i << " " << j;
				return 0;
			}
        }
    }
    cout << "No Solution";
    return 0;
}

小札

  1. 理解错误了 at least one but not all 的意思,导致怎么搞都没搞的出来
  2. 用两个数组存取读入的信息这个决定有些不妥,并且再后面判断是否说谎的时候犯了错误:
    (b[k] != result[a[k]]) 写成了(a[b[k]] != result[a[k]])
  3. 所用时间有些长具体各阶段时间并没有详细划分,不过总时间是一个半小时,难怪真正考试的时候又那么多同学被这道题卡住了。
  4. 思路很重要,看完liu神的思路发现
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值