1148 Werewolf - Simple Version

1148 Werewolf - Simple Version
题目链接
Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

player #1 said: “Player #2 is a werewolf.”;
player #2 said: “Player #3 is a human.”;
player #3 said: “Player #4 is a werewolf.”;
player #4 said: “Player #5 is a human.”; and
player #5 said: “Player #4 is a human.”.
Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:
If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence – that is, for two sequences A=a[1],…,a[M] and B=b[1],…,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:
5
-2
+3
-4
+5
+4
Sample Output 1:
1 4
Sample Input 2:
6
+6
+3
+1
-5
-2
+4
Sample Output 2 (the solution is not unique):
1 5
Sample Input 3:
5
-2
-3
-4
-5
-1
Sample Output 3:
No Solution
题目大意:已知在一群人中间有两个人扮演狼的角色,每人说一句表明另一个人身份的话。一头狼撒谎了,一个人也说了谎,现在需要找到扮演狼角色的人物。如果有多组可能的结果,则输出序列号最小的。如果没有答案,则输出No Solution。
分析:利用枚举方法解决问题。
先假定编号i,j两人扮演的狼这个角色,然后依次判定每个人的话是否正确,
判定结果中,如果有两人说谎,并且一人扮演狼的角色,一人扮演人的角色,则i,j,满足要求。
代码来源别处:

#include<iostream>
#include<vector>
#include<cmath>
using namespace std;
int main() {
	int n;
	cin >> n;
	vector<int>v(n + 1);
	for (int i = 1; i <= n; i++)
		cin >> v[i];
	for (int i = 1; i <= n; i++) {
		for (int j = i + 1; j <= n; j++) {
			vector<int>liar;
			vector<int>human(n + 1, 1);         //1表示人类,-1表示狼
			human[i] = -1; human[j] = -1;       //两头狼
			for (int k = 1; k <= n; k++) {      //判断假设是否正确
				if (v[k] * human[abs(v[k])] < 0)
					liar.push_back(k);
			}
			if (liar.size() == 2 && (human[liar[0]] + human[liar[1]] == 0)) {    //两个撒谎的,一个是人,另一个是狼
				cout << i << " " << j; return 0;
			}
		}
	}
	cout << "No Solution";
	return 0;
}

欢迎评论!!!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值