1148 Werewolf - Simple Version (20 分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

这是当时第一次考甲级,折磨了半天没出来的一道题,比较讽刺的是,一出考场收到一个狼人杀场地的推送短信(生平第一次emmm)。一把辛酸泪,考完有几天一直拒绝看这道题,后来忍不住群里的讨论,又来看了看。首先考暴力搜索就比较出乎我的意料,其次PAT的题(甲级)难度也还不是那么大,一定要注意隐含在题目中的提示,比如这题,不知道为何考试的时候,我一心一意的暴力搜索谎言家,明明最后要输出狼的序号。

暴搜狼。逐一判断每个人是够说谎。

#include <iostream>
#include <vector>
using namespace std;
int main(){
	int n;
	scanf("%d", &n);
	vector<int>word(n + 1);
	for(int i = 1; i <= n ; ++ i)
		scanf("%d", &word[i]);
	for(int i = 1; i <= n; ++ i)
		for(int j = i + 1; j <= n; ++ j){
			vector<int>liar(n + 1, 0);
			int cnt = 0, cntwolf = 0;
			for(int u = 1; u <= n; ++ u){
				if(word[u] < 0 && abs(word[u]) != i && abs(word[u]) != j)
					liar[u] = 1;
				else if(word[u] > 0 && (word[u] == i || word[u] == j))
					liar[u] = 1;
				cnt += liar[u];
				cntwolf += (liar[u] & (u == i || u == j));
				if(cnt > 2 || cntwolf > 1)
					break;
			}
			if(cnt == 2 && cntwolf == 1){
				printf("%d %d", i, j);
				return 0;
			}
		} 
	printf("No Solution");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值