【UVA】455 Periodic Strings

题目链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=396

题目:

 A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formed by 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (one repetition of ”abcabcabcabc”).

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2

分析:

求可以通过循环而组成指定字符串的字符串的最小长度。 如abcabc,由abc循环组成,abcabc的相应结果为3。可以通过k作为最小长度(即最终输出结果),然后利用周期的定义,满足条件的字符串会满足s[i+k]=s[i]。(不过要注意像abcdabc这样的串,如果不加限制条件len%k==0,也会把这种串当作周期串)

另外注意输入输出都要求两行间多一个空行!!!一开始没注意输出空行问题就PE了。还有非周期串,其周期长度为其本身长度。

代码:

#include <stdio.h>
#include <string.h>
int main()
{
	char s[83];
	int T,ans,i,k,len,ok;
	scanf("%d",&T);
	while (T--)
	{
		scanf("%s",s);
		len = strlen(s);
		ok = 0;
		for (k=1; k<len && !ok; k++)
		{
			for (i=0; i < len-k && !ok; i++)
			{
				if (s[i+k] != s[i])break;
				else if ( i== len-k-1 && s[i+k]==s[i] && len%k==0){ ok=1; ans=k;}
			}
		}
		if (ok)printf("%d\n",ans);
		else printf("%d\n",len);
		if (T != 0)printf("\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值