10.1 PAT 甲级 1044 Shopping in Mars

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10
​5
​​ ), the total number of diamonds on the chain, and M (≤10
​8
​​ ), the amount that the customer has to pay. Then the next line contains N positive numbers D
​1
​​ ⋯D
​N
​​  (D
​i
​​ ≤10
​3
​​  for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5

TLE版本

#include<iostream>
#include<algorithm>
using namespace std;

const int N = 100010, D = 1010;;

int n, m, t;
int mon[N];

int main()
{
    cin >> n >> m;
    for(int i = 1; i <= n; i ++)
    {
        scanf("%d", &t);
        mon[i] = mon[i - 1] + t;
    }
    
    int res = N * D;
    for(int i = 1; i <= n; i ++)
    {
        int j = i;
        
        while(mon[j] - mon[i - 1] < m && j <= n)    j ++;
        if(mon[j] - mon[i - 1] >= m)    res = min(res, mon[j] - mon[i - 1]);
    }
    
    for(int i = 1; i <= n; i ++)
    {
        int j = i;
        
        while(mon[j] - mon[i - 1] < m && j <= n)    j ++;
        if(mon[j] - mon[i - 1] == res)  printf("%d-%d\n", i, j);
    }
            
    return 0;
}

改进版本:

两个指针一前一后,如果数据过小,后指针就往后走,总和大于等于m了,就前指针往后走,用反证法可以证明,一旦找到一对指针之间的总和为m或者是最接近m的数了,后指针往后走的时候,前指针也是一定往前走的。

#include<iostream>
#include<algorithm>
using namespace std;

const int N = 100010, D = 1010;;

int n, m, t;
int mon[N];

int main()
{
    cin >> n >> m;
    for(int i = 1; i <= n; i ++)
    {
        scanf("%d", &t);
        mon[i] = mon[i - 1] + t;
    }
    
    int res = N * D;
    for(int i = 1, j = 1; i <= n; i ++)
    {
        while(mon[i] - mon[j] >= m)    j ++;
        if(mon[i] - mon[j - 1] >= m)    res = min(res, mon[i] - mon[j - 1]);
    }
    
    for(int i = 1, j = 1; i <= n; i ++)
    {
        while(mon[i] - mon[j] >= m)    j ++;
        if(mon[i] - mon[j - 1] == res)  printf("%d-%d\n", j, i);
    }
            
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值