线段树模板 poj3468

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 115916 Accepted: 36013
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source



模板:
#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int N =200011;
LL tree[N<<2];
LL lazy[N<<2];
LL a[N];
void updata(int n)
{
    tree[n]=tree[n<<1]+tree[n<<1|1];
}
void pushdown(int l,int r,int n)
{
    if(lazy[n])
    {
        int m=(l+r)>>1;
        lazy[n<<1]=lazy[n<<1]+lazy[n];
        lazy[n<<1|1]=lazy[n<<1|1]+lazy[n];
        tree[n<<1]=tree[n<<1]+(m-l+1)*lazy[n];
        tree[n<<1|1]=tree[n<<1|1]+(r-m)*lazy[n];
        lazy[n]=0;
    }
}
void build(int l,int r,int n)
{
    lazy[n]=0;
    if(l==r)
    {
        tree[n]=a[l];
        return ;
    }
    int m=(l+r)>>1;
    build(l,m,n<<1);
    build(m+1,r,n<<1|1);
    updata(n);
    return ;
}
LL query(int l,int r,int n,int a,int b)
{
    if(l>=a&&r<=b)
        return tree[n];
    pushdown(l,r,n);
    int m=(l+r)>>1;
    LL ans=0;
    if(a<=m)
        ans+=query(l,m,n<<1,a,b);
    if(b>m)
        ans+=query(m+1,r,n<<1|1,a,b);
    return ans;
}
void add(int l,int r,int n,int a,int b,LL k)
{
    if(l>=a&&r<=b)
    {
        lazy[n]+=k;
        tree[n]=tree[n]+(r-l+1)*k;
        return ;
    }
    pushdown(l,r,n);
    int m=(l+r)>>1;
    if(a<=m)
        add(l,m,n<<1,a,b,k);
    if(b>m)
        add(m+1,r,n<<1|1,a,b,k);
    updata(n);
    return ;
}
int main()
{
    int n,m,i;
    while(scanf("%d",&n)!=EOF)
    {
        scanf("%d",&m);
        for(i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        build(1,n,1);
        char q;
        int l,r;
        LL k;
        while(m--)
        {
            scanf(" %c%d%d",&q,&l,&r);
            if(q=='Q')
                printf("%lld\n",query(1,n,1,l,r));
            else if(q=='C')
            {
                scanf("%lld",&k);
                add(1,n,1,l,r,k);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值