A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:
- Line #1: the 7-digit ID number;
- Line #2: the book title -- a string of no more than 80 characters;
- Line #3: the author -- a string of no more than 80 characters;
- Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
- Line #5: the publisher -- a string of no more than 80 characters;
- Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.
After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:
- 1: a book title
- 2: name of an author
- 3: a key word
- 4: name of a publisher
- 5: a 4-digit number representing the year
Output Specification:
For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print
Not Found
instead.Sample Input:
3 1111111 The Testing Book Yue Chen test code debug sort keywords ZUCS Print 2011 3333333 Another Testing Book Yue Chen test code sort keywords ZUCS Print2 2012 2222222 The Testing Book CYLL keywords debug book ZUCS Print2 2011 6 1: The Testing Book 2: Yue Chen 3: keywords 4: ZUCS Print 5: 2011 3: blablabla
Sample Output:
1: The Testing Book 1111111 2222222 2: Yue Chen 1111111 3333333 3: keywords 1111111 2222222 3333333 4: ZUCS Print 1111111 5: 2011 1111111 2222222 3: blablabla Not Found
题意:图书管理系统
- 输入N本书的 书名、作者、关键词(空格隔开)、出版商、出版年份
- 对给定的M个询问作出对应的回答输出
- 输出对应书名、作者、关键词(是某书关键词之一即可)、出版商、出版年份的book的id,从小到大排列
思路:
- 选择容器:五大信息对应string 分别有一堆ID(输出时从小到大),即一信息多string,一string多id,故选用map<string,set<int> >
- 传参引用更节省时间
- scanf()接收遇到空格、回车停止,但不包含空格和回车
- getline(),按行读入,含回车
- 读入一行带空格的字符,依次读入,空格略去,回车跳出
while(cin>>s) {
key[s].insert(id);
ch=getchar();
if(ch=='\n') break;
}
- M次询问必须分开!!!因为map中只取部分作为string
- 输出格式注意 恢复前面的0
#include<iostream>
#include<map>
#include<set>
#include<string>
#include<algorithm>
using namespace std;
//选好容器很重要
map<string,set<int> > title, author, key, publisher, year;
void query(map<string,set<int> > &mp,string &s) {
if(mp.find(s)!=mp.end())
for(auto it=mp[s].begin(); it!=mp[s].end(); it++)
printf("%07d\n",*it); //0补全,it实为指针
else cout<<"Not Found\n";
}
int main() {
int n,m,id;
string s;
char ch;
scanf("%d\n",&n);
for(int i=0; i<n; i++) {
scanf("%d\n",&id);
getline(cin,s);
title[s].insert(id);
getline(cin,s);
author[s].insert(id);
while(cin>>s) { //一行带空格的字符,依次读入,空格略去,回车跳出
key[s].insert(id);
ch=getchar();
if(ch=='\n') break;
}
getline(cin,s);
publisher[s].insert(id);
getline(cin,s);
year[s].insert(id);
}
scanf("%d\n",&m);
int num;
for(int i=0; i<m; i++) {
scanf("%d: ",&num); //一定要分开,因为下标只含后续字母!!!
getline(cin,s);
cout<<num<<": "<<s<<endl;
if(num==1) query(title,s);
else if(num==2)query(author,s);
else if(num==3) query(key,s);
else if(num==4) query(publisher,s);
else if(num==5) query(year,s);
}
return 0;
}