Longest Ordered Subsequence

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题意:最长上升子序列的长度(基础背包)

问题分析:  这是一个最长上升子序列问题,使用DP算法实现。
                    定义dp[i]=以a[i]为末尾的最长上升子序列的长度,那么,以a[i]为末尾的最长上升子序列有以下两种情形:
                    1.只包含a[i]的子序列
                    2.满足j<i并且a[j]<a[i]的以a[j]为结尾的上升子序列末尾,追加上a[i]后得到的子序列
                    得状态方程:dp[i]=max{1,dp[j]+1|j<i且a[j]<a[i]}
 

注意:不是多组输入!

           自己手动测试的时候一定要加“//”!

           弱小无助又可怜的我“哇”的一声哭出来~~(好像...戏有点多?哈哈)

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
int a[1005];
int b[1005];
int main() {
	int n;
	scanf("%d",&n);
	for(int i=1; i<=n; i++) {
		scanf("%d",&a[i]);
		b[i]=1;
	}
	int maxn=-1;
	for(int i=1; i<=n; i++) {
		for(int j=1; j<i; j++) {
			if(a[i]>a[j])
				b[i]=max(b[i],b[j]+1);
		}
		maxn=max(maxn,b[i]);
	}
	printf("%d\n",maxn);

	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值