PAT A1031

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

给任意一个字符串包括N个字符,N>=5,你被告知 把 字符排列成 U 的形状。例如,helloworld 可以被打印成下面这样:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

字符必须被以原始的顺序打印出来,从左面 垂直向下有 n1 个字符,然后 在底部从左到右 有 n2 个字符,最后 向上有 n3 个字符。你必须让 U 形状尽可能 方,n1+n3+n2 - 2 = N

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

每个用例包含一个不少于 5 个,不多于 80 个字符的字符串,字符串没有空格

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

对于每个用例,打印除 U 的形状 就像描述的一样

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

 思路:

分别列出几个不同字母数的单词,找规律发现,行和列数的规律,其中,行列还要根据题目中所给的公式得出。因为最后一行的输出方式与其他行不同,所以把最后一行在最后单独遍历输出,第一到倒数第二行的规律相同,都是输出第一个和最后一个字母,中间部分输出空格。

代码:

#include <cstdio>
#include <string.h>
int main(){
	int row;
	char str[90];
	scanf("%s", str);
	int len = strlen(str);
	row = (len+2)/3;	
	int col;
	col = len - (2 * row) + 2;
	for(int i = 0; i < row-1; i++){
		for(int j = 0; j < col; j++){
			if(j == 0)
				printf("%c", str[i]);
			else if(j == col-1)
				printf("%c", str[len-i-1]);
			else
				printf(" ");
		}
		printf("\n");
	}
	for(int j = 0; j < col; j++){
		printf("%c", str[row-1+j]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值