PAT A 甲级 1037 Magic Coupon (25分)

1037 Magic Coupon (25分)

吐槽

这题目是真的难懂。读题时间和编程时间可能是一个级别的。

逻辑

先搞清楚这题目要干啥:
有一堆coupon,是一堆数,有正有负。
有一堆product,是一堆数,有正有负。
两堆里面各拿出一个,数字乘一乘,就是你的所得。
重复各拿一个相乘的操作,直到你主动停止(即:可以不用光所有数)。
问怎么拿得到的所得最多,并求这个最大所得。

这里需要一个简单的数学思考——最佳的拿取方法是什么。
首先正负分开,必然两个都正或两个都负的拿,不然不如不拿。
其次,每次应该拿出coupon中绝对值最大的,和product中同号的里绝对值最大的那个。
搞清楚这个了就知道是个很简单的排列-循环拿出顶端的操作了。

题目

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons N
​C
​​ , followed by a line with N
​C
​​ coupon integers. Then the next line contains the number of products N
​P
​​ , followed by a line with N
​P
​​ product values. Here 1≤N
​C
​​ ,N
​P
​​ ≤10
​5
​​ , and it is guaranteed that all the numbers will not exceed 2
​30
​​ .

Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3

Sample Output:
43

代码

#include<iostream>
#include<queue>

using namespace std;

int main()
{
	priority_queue<int> poc;
	priority_queue<int> boc;
	priority_queue<int> pop;
	priority_queue<int> bop;
	int n;
	int i;
	int tempi;
	cin >> n;
	for (i = 0; i < n; i++)
	{
		cin >> tempi;
		if (tempi > 0)
			poc.push(tempi);
		else
		{
			tempi = -tempi;
			boc.push(tempi);
		}
	}
	cin >> n;
	for (i = 0; i < n; i++)
	{
		cin >> tempi;
		if (tempi > 0)
			pop.push(tempi);
		else
		{
			tempi = -tempi;
			bop.push(tempi);
		}
	}
	int sum, c, p;
	sum = 0;
	while (!poc.empty() && !pop.empty())
	{
		c = poc.top();
		poc.pop();
		p = pop.top();
		pop.pop();
		sum += c * p;
	}
	while (!boc.empty() && !bop.empty())
	{
		c = boc.top();
		boc.pop();
		p = bop.top();
		bop.pop();
		sum += c * p;
	}
	cout << sum;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值