9044:字符串转为整数

23 篇文章 0 订阅

Problem Description

用递归算法将一个整数字符串转换为相应的整数并输出,如"123"转换输出为123。

 Input

有多组数据,每组为由10个数字字符或正、负符号组成的一个整数字符串,正、负符号只可能会出现在首字符,序列长度不超过9。

 Output

输出该字符串转换得到的相应整数。

 Sample Input

+123
0123

 Sample Output

123
123

 

#include<iostream>
#include<stdio.h>
#include<string.h>
const int MAX=51;
using namespace std;

void fun(int strlen,char* str,int * array,int i,int& count) {
    if(i==strlen-1) {
        array[count++]=str[i]-'0';
    } else {
        if(i==0&&str[i]=='+')
            fun(strlen,str,array,i+1,count);
        else if(str[i]=='0'&&count==0)
            fun(strlen,str,array,i+1,count);
        else if(count==1&&array[0]<0&&str[i]=='0')
            fun(strlen,str,array,i+1,count);

        else {
            array[count++]=str[i]-'0';
            fun(strlen,str,array,i+1,count);
        }
    }
}




void print(int* array,int len) {
    int flag=0;
    if(array[0]<0) {
        flag=1;
        if(array[1]!=0)
            cout<<"-";
    }
    for(int i=flag; i<len; i++)
        cout<<array[i];
    cout<<endl;

}



int main() {
    int n;
    int array[MAX];
    char str[MAX];
    while(cin>>str) {
        int len=strlen(str);
        int count=0;
        fun(len,str,array,0,count);
//cout<<count<<endl;
        print(array,count);

    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

haibianyoushark

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值