1001 A+B Format (20 分)
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10
6
≤a,b≤10
6
. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int main()
{
int a,b;
cin>>a>>b;
int sum = a + b;
int flag = 0;
if(sum < 0)
cout<<"-";
int s[100],i = 0;
memset(s,0,sizeof(s));
sum = abs(sum);
if(sum == 0)
cout<<"0";
while(sum)
{
s[i++] = sum % 10;
sum = sum / 10;
flag++;
if(flag == 3 && sum)
{
flag = 0;
s[i++] = 99; //标记逗号的位置
}
}
for(int j = i-1;j >= 0;j--)
{
if(s[j] == 99)
cout<<",";
else
cout<<s[j];
}
return 0;
}