HDU 1009 FatMouse' Trade

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 92371    Accepted Submission(s): 32023


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
 
 
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
 
 
13.333 31.500
 

Author
CHEN, Yue
 

Source

心很累;;;

这是我的错误代码; 输入 0 1  1 0 的时候  会输出nan;;;无语。。。

#include <iostream>
#include <string>
#include <algorithm>
#include <iomanip>
using namespace std;
struct room
{
	double bean,meat;//用肉换豆,
	double m;//一个豆能换多少钱 
}r[10001];
double cmp(room a,room b)
{
	return a.m>b.m;
}
int main()
{
	int m,n;
	while(cin>>m>>n)
	{
		if(m==-1&&n==-1)
		break;	
		for(int i=0;i<n;i++)//豆  肉 
		{
			cin>>r[i].bean>>r[i].meat;
			r[i].m=1.0*r[i].bean/r[i].meat;	
		}
		sort(r,r+n,cmp);
		double sum=0;
		for(int i=0;i<n;i++)
		{
			if(m>=r[i].meat)
			{
				m-=r[i].meat;
				sum+=r[i].bean;
			}else {
				sum+=m*r[i].m;
				break;
			}
		}
		cout<<fixed<<setprecision(3)<<sum<<endl;
	}
	return 0;
} 

这是别人的代码;;;;ac的

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct Node{
   double J;//每个房间有J磅豆子
   double F;//需要我付出F磅猫食
   double bi;//J和F的比值
}result[10000];
/**
  用来进行比较
*/
bool cmp(Node a,Node b){
   return a.bi>b.bi;
}
int main(){
   int m,n,i;
   double re;//表示有m磅猫食,n个房间
   while(scanf("%d%d",&m,&n)&&m!=-1&&n!=-1){
      re=0;
      for(i=0;i<n;i++){
         cin>>result[i].J>>result[i].F;
         //将J和F的比值录入
         result[i].bi=result[i].J/result[i].F;
      }
      sort(result,result+n,cmp);
      for(i=0;i<n;i++){
          if(m>=result[i].F){
              m-=result[i].F;
              re+=result[i].J;
          }else{
              re+=m*result[i].bi;
              break;
          }
      }
      printf("%.3lf\n",re);
   }return 0; 
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值