POJ-3259-Wormholes

20 篇文章 0 订阅
7 篇文章 0 订阅

Wormholes

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 61389 Accepted: 22893

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

看这个农夫能不能回到过去。

农夫约翰有F个农场,每个农场有N块地,其间有M条路,W条时光隧道(时间倒流)。就是当你过去的时候时间会倒退Ts。我们的任务是知道会不会在从某块地出发后又回来,看到了离开之前的自己。就是N个点m条边,先给出了一个图,然后有W个虫洞,虫洞有穿越时光的作用,比如从a-->b的权为-c,用folyd找负权回路,容易超时...

我用G++超时了 。 C++没有,现附上floyd代码

/*
N 牧场 M 代表路径 W代表虫洞
F 农场
S ,E T 起点 终点 时间 双向路
W:代表 单项路从S->E 回溯到Ts

*/
#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
#define N 505
#define M 2600
#define W 202
#define inf 0x3f3f3f3f
int map[N][N],n,w,m,f,flag;
void floyd()
{
    int i,j,k;
    for(k=1;k<=n;k++)
    {
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(map[i][j]>map[i][k]+map[k][j])
                {
                    map[i][j]=map[i][k]+map[k][j];
                }
            }
            if(map[i][i]<0)
            {
                flag=1;
                break;
            }
        }
    }
}
int main()
{
    //freopen("c.in","r",stdin);
    //freopen("c.out","w",stdout);
    cin>>f;
    while(f--)
    {
        cin>>n>>m>>w;
        for(int i=1;i<=n;i++)//初始化
        {
            for(int j=1;j<=n;j++)
            {
                if(i==j) map[i][j]=0;
                else map[i][j]=map[j][i]=inf;
            }
        } 
        int a,b,c;
        for(int i=0;i<m;i++)//双向路
        {
            cin>>a>>b>>c;
            if(map[a][b]>c)
            {
                map[a][b]=map[b][a]=c;
            }
        }
        for(int i=0;i<w;i++)//单项路
        {
            cin>>a>>b>>c;
            map[a][b]=-c;
        }
        flag=0;
        floyd();
        if(flag) cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值