HDU 6025 Coprime Sequence

Coprime Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3055    Accepted Submission(s): 1418

Problem Description

Do you know what is called ``Coprime Sequence''? That is a sequence consists of n positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

Input

The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.
In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of n integers a1,a2,...,an(1≤ai≤109), denoting the elements in the sequence. 

Output

For each test case, print a single line containing a single integer, denoting the maximum GCD.

Sample Input

3

3

1 1 1

5

2 2 2 3 2

4

1 2 4 8

Sample Output

1

2

2

Source

2017中国大学生程序设计竞赛 - 女生专场

利用 前缀 gcd 后缀 gcd

//对于每个询问,晨晨需要找到序列{ai}的所有连续子序列,
//求出每个子序列异或的结果,
//找到所有的结果中与 xi之差的绝对值最小的一个,
//并告诉小璐相应子序列的长度
//此题:移出一个数 使得其他数的最大公约数最大,输出最大公约数
/*
依次遍历每个数,
算出这个数左边的一堆数的最大公约数b,
再算出这个数右边的一堆数的最大公约数c,
gcd(b,c)即为删去当前数后剩下的数的最大公约数。
遍历每个数得到的最大gcd即为所求。
*/
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <cmath>
#include <stack>
#include <cstdio>
#include <vector>
using namespace std;
#define maxx 100005
#define inf 0x3f3f3f3f
#define pi acos(-1.0)
#define ll long long
int a[maxx];
int b[maxx];
int c[maxx];
int gcd(int a,int b)
{
    while(b)
    {
        int c=a%b;
        a=b;
        b=c;
    }
    return a;
}
int main()
{
    int t,n;
    cin>>t;
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
        }
        int maxxx=-1;
        b[1]=a[1];
        for(int i=2;i<=n;i++)
        {
            b[i]=gcd(b[i-1],a[i]);
        }
        c[n]=a[n];
        for(int i=n-1;i>=1;i--)
        {
            c[i]=gcd(c[i+1],a[i]);
        }
        //删去最后一个数 删去第一个数看哪个gcd大
        maxxx=max(b[n-1],c[2]);
        for(int i=2;i<=n-1;i++)
        {//表示删去i
            maxxx=max(maxxx,gcd(b[i-1],c[i+1]));
        }
        cout<<maxxx<<endl;
    }return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值