《算法笔记》6.4小节 问题 A: Speech Patterns (25)

题目描述

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

输入

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

输出

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

样例输入

Can1: "Can a can can a can?  It can!"

样例输出

can 5

思路:

从一句话中找出最多的那个单词,用map建立从string到int的映射,要注意的一点是单词包括字母和数字,

遇到不合格字符的时候即代表单词的结束

#include<bits/stdc++.h>
#include<map>
using namespace std;
bool numordigit(char ch)
{
    if(isalpha(ch))return true;
    if(ch>='0'&&ch<='9')return true;
    return false;
}

int main()
{
    string str;
    string word;
    map<string, int>mp;

    getline(cin,str);
    for(int i=0;i<str.length();i++)
    {
        if(numordigit(str[i]))
        {
            if(isupper(str[i]))
                str[i]+=32;
            word+=str[i];
        }
        if(numordigit(str[i])==0||i==str.length()-1)
        {
            if(word.length()!=0)
                mp[word]++;
            word.clear();
        }
    }
        int mx=-1;
        string ans;
        map<string,int>::iterator it;
        for(it=mp.begin();it!=mp.end();it++)
        {
            if(it->second>mx)
            {
                mx=it->second;
                ans=it->first;
            }
        }

        cout<<ans<<' '<<mx;
        return 0;




}

 

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值