PAT-A1071 Speech Patterns 题目内容及题解

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

题目大意

给定一段文本,从中找到出现最频繁的单词。在一行中输出文本中最常见的单词及其次数。如果有多个这样的单词,按字典顺序打印最小的一个。单词不区分大小写。

解题思路

  1. 读入输入字符;
  2. 将其分解成合适的单词,并统一转化为小写字母形式;
  3. 用map容器对单词进行计数;
  4. 输出结果并返回零值。

代码

#include<iostream>
#include<string>
#include<map>
using namespace std;

bool check(char c){
    if(c>='0'&&c<='9'){
        return true;
    }
    if(c>='A'&&c<='Z'){
        return true;
    }
    if(c>='a'&&c<='z'){
        return true;
    }
    return false;
}

int main(){
    int i,max=0;
    map<string,int>count;
    string str,word,fre;
    map<string,int>::iterator it;
    getline(cin,str);
    i=0;
    while(i<str.length()){
        word.clear();
        while(i<str.length()&&check(str[i])==true){
            if(str[i]>='A'&&str[i]<='Z'){
                str[i]+=32;
            }
            word+=str[i];
            i++;
        }
        if(word!=""){
            if(count.find(word)==count.end()){
                count[word]=1;
            }else{
                count[word]++;
            }
        }
        while(i<str.length()&&check(str[i])==false){
            i++;
        }
    }
    for(it=count.begin();it!=count.end();it++){
        if(it->second>max){
            max=it->second;
            fre=it->first;
        }
    }
    cout<<fre<<' '<<max<<endl;
    return 0; 
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值