[PAT-A] 1071 Speech Patterns(25)

查看更多关于PAT的技术文档


题目描述
People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar. Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:
Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:
For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.
Note that words are case insensitive.

Sample Input:
Can1: "Can a can can a can? It can!"
Sample Output:
can 5

题目分析
题目大意:统计一句话中出现最多的单词,并且输出重复次数.如果次数一样多,则输出字典序最小的那个.注意单词只可以由[0-9 A-Z a-z]组成.

解题思路:map映射.将一句话拆成一个个单词,并统计单词出现的个数即可.
  • 在统计单词的时候需要将字母统一为小写字母或者大写字母
  • 一个一个字符的读取构成一个完整的单词,从而进行统计该单词出现的次数
  • 在读取到非[0-9 A-Z a-z]中的字符时候,也就标志着单词读取完毕,开始统计出现次数

代码设计
//AC代码
//zhicheng
#include<cstdio>
#include<iostream>
#include<cctype>
#include<string>
#include<map>
using namespace std;
// zhicheng
// October,10,2018
map<string,int> m;
int main()
{
    string re="",s,tmp="";int num=0;
    getline(cin,s);
    for(int i=0,len=s.length();i<len;i++)
    {
        if(isalnum(s[i])){s[i]=tolower(s[i]);tmp=tmp+s[i];}// 将一个个字母创成全是小写的单词
        if(tmp!=""&&(!isalnum(s[i])||i==len-1))// 标志前一个单词读取结束,开始进行统计该单词出现的次数
        {
            m[tmp]++;
            if((num<m[tmp])||(num==m[tmp]&&re>tmp)){num=m[tmp];re=tmp;}
            tmp="";
        }
    }
    printf("%s %d\n",re.c_str(),num);
    return 0;
}

传送门

有关PAT (Basic Level) 的更多内容可以关注 ------> PAT-B题解
有关PAT (Advanced Level) 的更多内容可以关注 ------> PAT-A题解

铺子日常更新,如有错误请指正
题目链接 - 技术文档

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值