PAT (Advanced Level) Practice 1045

127 篇文章 0 订阅
119 篇文章 0 订阅

1045 Favorite Color Stripe (30 分)

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10​4​​) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

分析:题意为找出符合按最喜爱顺序排列的子序列的最长值。这里可以作为一个最长不下降子序列问题来处理,这里比较的值为子序列中元素在喜爱顺序中的索引。在输入序列时,将所有不在喜爱顺序中的值全部剔除出去,之后按照最长不下降子序列问题来写转移方程即可。

代码: 

#include<iostream>
#include<algorithm>
#include<vector>
#define MAXM 201
using namespace std;
int main() {
	int N, M, L;
	int index = 0;
	int maxN = -1;
	cin >> N;
	cin >> M;
	vector<int> fav(MAXM);
	for (int i = 1; i <= M; i++) {
		int temp;
		cin >> temp;
		fav[temp] = i;
	}
	cin >> L;
	vector<int> color(L);
	for (int i = 0; i < L; i++) {
		int temp;
		cin >> temp;
		if (fav[temp] != 0) {
			color[index++] = temp;
		}
	}
	vector<int> dp(L);
	for (int i = 0; i < index; i++) {
		dp[i] = 1;
		for (int j = 0; j < i; j++) {
			if (fav[color[i]] >= fav[color[j]]) {
				dp[i] = max(dp[i], dp[j] + 1);
			}
		}
		maxN = max(dp[i], maxN);
	}
	cout << maxN << endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值