PAT甲级1002

1002 A+B for Polynomials (25point(s))

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output: 

3 2 1.5 1 2.9 0 3.2

题目大意:两个k次多项式相加。
解题思路:用arr[i]表示i次项的系数,然后边读入边累加即可。

Java代码:

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		float arr[] = new float[1005];
		int m = sc.nextInt();
		int a, cnt = 0;
		for(int i=0; i<m; i++)
		{
			a = sc.nextInt();
			arr[a] += sc.nextFloat();			
		}
		int n = sc.nextInt();
		for(int i=0; i<n; i++)
		{
			a = sc.nextInt();
			arr[a] += sc.nextFloat();
		}
		for(int i=0; i<1005; i++)
		{
			if(arr[i]!=0) cnt++;
		}
		System.out.print(cnt);
		for(int i=1004; i>=0; i--)
		{
			if(arr[i]!=0) System.out.print(" "+i+" "+String.format("%.1f", arr[i]));
		}
	}
}

C++代码:

#include <iostream>
using namespace std;
int main()
{
    float arr[1005] = {0};
    int m, n, a;
    float b;
    scanf("%d", &m);
    for (int i = 0; i < m; i++)
    {
        scanf("%d %f", &a, &b);
        arr[a] += b;
    }
    scanf("%d", &n);
    for (int i = 0; i < n; i++)
    {
        scanf("%d %f", &a, &b);
        arr[a] += b;
    }
    int cnt = 0;
    for (int i = 0; i < 1005; i++)
    {
        if (arr[i] != 0)
            cnt++;
    }
    printf("%d", cnt);
    for (int i = 1004; i >= 0; i--)
    {
        if (arr[i] != 0)
            printf(" %d %.1f", i, arr[i]);
    }
    return 0;
}

注意:输出时一定要规范小数点后一位,不然有一个测试用例无法通过。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值