HDU-1015 Safecracker (全排列搜索)


Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST ===
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."

v - w^2 + x^3 - y^4 + z^5 = target

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."
 

Sample Input
 
 
1 ABCDEFGHIJKL11700519 ZAYEXIWOVU3072997 SOUGHT1234567 THEQUICKFROG0 END
 
Sample Output
 
 
LKEBAYOXUZGHOSTno solution


题目大意:输入taeget,还有一个串。
找出满足v - w^2 + x^3 - y^4 + z^5 = target 的五个字母(字母在字母表中的位置是其代表的数字)
按字典序输出最大的满足条件的五个字母

感受:使用全排列暴力搜索,注意要对串中的字母预处理,将它们从大到小排序。

预处理很重要!!!


AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;

int vis[27];
int temp[27];
int k[27];
int res[6];
int len,flag;
int target;

bool cmp(int a,int b)
{
	return a>b;
}

void  DFS(int n)
{
	if(n==5)
	{
		int x=k[0]-k[1]*k[1]+k[2]*k[2]*k[2]-k[3]*k[3]*k[3]*k[3]+k[4]*k[4]*k[4]*k[4]*k[4]; 
		if(x==target&&flag==0)     //flag==0 是一个减少过程的关键 
		{
			for(int j=0;j<5;j++)
			{
				res[j]=k[j];	
			}
			flag=1;		
		}
		return ;
	}
	
	for(int i=0;i<len;i++)
	{
		if(!vis[i])
		{
			vis[i]=true;
			k[n]=temp[i];
			DFS(n+1);
			vis[i]=false;
		}
		
	}
	
}

int main()
{
	char str[27];
	while(~scanf("%d%s",&target,&str))
	{
		if(target==0&&strcmp(str,"END")==0)//str=="END"  这样的写法是错的 
			break;
		memset(vis,0,sizeof(vis));	
		memset(temp,0,sizeof(temp));	
		memset(res,0,sizeof(res));
		memset(k,0,sizeof(k));		
		flag=0;	
			
		len=strlen(str);
	  
		
		for(int i=0;i<len;i++)
			temp[i]=str[i]-'A'+1;   //A为1  char类型直接转换成int 
	   
	    //预处理 将字典序大的放在前面,排序后DFS输出的第一个答案就是最大的 	
		sort(temp,temp+len,cmp);
			
		DFS(0);
		if(flag==1)
		{
			for(int i=0;i<5;i++)
				printf("%c",res[i]+'A'-1);    //直接将int类型转换成char 
			printf("\n");
		}
		else
			printf("no solution\n");
			
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值