hdu:5805:前缀和后缀NanoApe Loves Sequence

Problem Description
NanoApe, the Retired Dog, has returned back to prepare for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with n numbers on the paper and then randomly deleted a number in the sequence. After that, he calculated the maximum absolute value of the difference of each two adjacent remained numbers, denoted as F.

Now he wants to know the expected value of F, if he deleted each number with equal probability.

Input
The first line of the input contains an integer T, denoting the number of test cases.

In each test case, the first line of the input contains an integer n, denoting the length of the original sequence.

The second line of the input contains n integers A1,A2,…,An, denoting the elements of the sequence.

1≤T≤10, 3≤n≤100000, 1≤Ai≤109

Output
For each test case, print a line with one integer, denoting the answer.

In order to prevent using float number, you should print the answer multiplied by n.

Sample Input
1
4
1 2 3 4

Sample Output
6

思路:
删掉某一个数,剩下的将是此数的前缀和后缀(第一个数和最后一个数除外),那要加上的值必将是前缀,后缀,新产生的值,三者之中的最大值;

#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn=100009;
int t,n,a[maxn],b[maxn],c[maxn];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        scanf("%d",&a[0]);
        b[0]=0;
        for(int i=1; i<n; i++)
        {
            scanf("%d",&a[i]);
            b[i]=max(b[i-1],abs(a[i]-a[i-1]));//处理前缀,保留最大值
        }
        c[n-1]=abs(a[n-1]-a[n-2]);
        for(int i=n-2; i>0; i--)
        {
            c[i]=max(c[i+1],abs(a[i]-a[i-1]));//处理后缀
        }
        c[0]=0;
        long long ans=0;
        for(int i=0;i<n;i++)
        {
            int t=0;//巧妙化解
            if(i>1) t=max(t,b[i-1]);//此时有前缀
            if(i+2<n) t=max(t,c[i+2]);//此时有后缀
            if(i>0&&i<n-1) t=max(t,abs(a[i-1]-a[i+1]));//此时有新产生的值
            ans+=t;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值