HDU - 1372 Knight Moves

8 篇文章 0 订阅

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. 
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 

 

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 

 

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.". 

 

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

 

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

题目大意:在国际象棋8*8棋盘中,a-h从左到右表示第i列,1-8从上到下表示第j行 ,给你两个位置s,e,输出骑士从s走到e移动的次数

解题思路:最短路径bfs模板题,唯一主义的就是骑士的走法,首先你要知道国际象棋中骑士的走法,简单的说就是两步一拐,列如骑士刚开始在坐标的原点,骑士的走法是可以先横着走两格,然后可以选择向上或者向下走一格。此时的位置就是骑士从原点走一步的落点位置。当然也可以竖着走两格,然后向左或者向右走一个,所以骑士走一步的落点位置有8个,知道这个规则,题就好做了

AC代码:

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
int vis[10][10],map[10][10];
int dir[8][2]={2,1,2,-1,-2,1,-2,-1,1,2,-1,2,1,-2,-1,-2};//8个方向 
char s[3],e[3];
int sx,sy,ex,ey;
struct node{
	int x,y,step;
}now,nextt;
int bfs()
{
	memset(vis,0,sizeof(vis));
	queue<node>q;
	now.x=sx;
	now.y=sy;
	now.step=0;
	q.push(now);
	vis[now.y][now.x]=1;
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		if(now.x==ex&&now.y==ey)
			return now.step;
		for(int i=0;i<8;i++)
		{
			nextt.x=now.x+dir[i][0];
			nextt.y=now.y+dir[i][1];
			nextt.step=now.step+1;
			if(nextt.x>=0&&nextt.x<8&&nextt.y>=0&&nextt.y<8&&!vis[nextt.y][nextt.x])
			{
				q.push(nextt);
				vis[nextt.y][nextt.x]=1;
			}
		}
	}
}
int main()
{
	while(scanf("%s%s",s,e)!=EOF)
	{
		int ans=0;
		sx=s[0]-'a';
		sy=s[1]-'1';
		ex=e[0]-'a';
		ey=e[1]-'1';
		ans=bfs();
		printf("To get from %s to %s takes %d knight moves.\n",s,e,ans);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值