数据结构实验之二叉树七:叶子问题

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。

Input
  输入数据有多行,每一行是一个长度小于 50 个字符的字符串。
Output
  按从上到下从左到右的顺序输出二叉树的叶子结点。
Example Input
abd,,eg,,,cf,,,
xnl,,i,,u,,
Example Output
dfg
uli

用层序遍历的方法实现一层层的输出叶子数。

#include <bits/stdc++.h>
#include <string.h>
using namespace std;
int cnt, k, n;
char a[51], b[51];
struct node
{
    char data;
    struct node *l, *r;
};
struct node *create()
{
    struct node *root;
    root=(struct node*)malloc(sizeof(struct node));
    if(a[++cnt]==',')
        root = NULL;
    else
    {
        if(a[cnt])
        {
            root->data = a[cnt];
            root->l = create();
            root->r = create();
        }
    }
    return root;
}
void shuchu(struct node *root)
{
    int in=0, out=0;
    struct node *a[100];
    a[in++] = root;
    while(in>out)
    {
        if(a[out])
        {
            if(!a[out]->l&&!a[out]->r)
                cout << a[out]->data;
            a[in++]=a[out]->l;
            a[in++]=a[out]->r;
        }
        out++;
    }
}
int main()
{
    while(~scanf("%s", a))
    {
        struct node *root;
        cnt = -1;
        root = create();
        shuchu(root);
        cout << endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值