Problem E: 平面上的点和线——Point类、Line类 (V)

Problem E: 平面上的点和线——Point类、Line类 (V)

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 6517   Solved: 3221
[ Submit][ Status][ Web Board]

Description

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段。现在我们封装一个“Point类”和“Line类”来实现平面上的点的操作。
根据“append.cc”,完成Point类和Line类的构造方法和show()方法,输出各Line对象和Point对象的构造和析构次序。
接口描述:
Point::show()方法:按格式输出Point对象。
Line::show()方法:按格式输出Line对象。
Line::SetLine(double, double, double, double)方法:设置Line对象起点的x,y坐标(第一个和第二参数)和终点的x,y坐标(第三个和第四个坐标),并返回本对象
Line::SetLine(const Point &, const Point &)方法:设置Line对象的起点(第一个参数)和终点(第二个坐标),并返回本对象
Line::SetLine(const Line&)方法:设置Line对象,复制参数的坐标,并返回本对象
Line::readLine()方法:从标准输入上读入坐标,格式见Sample

Input

输入的第一行为N,表示后面有N行测试样例。
每行为两组坐标“x,y”,分别表示线段起点和终点的x坐标和y坐标,两组坐标间用一个空格分开,x和y的值都在double数据范围内。

Output

输出为多行,每行为一条线段,起点坐标在前终点坐标在后,每个点的X坐标在前,Y坐标在后,Y坐标前面多输出一个空格,用括号包裹起来。输出格式见sample。
C语言的输入输出被禁用。

Sample Input

40,0 1,11,1 2,32,3 4,50,1 1,0

Sample Output

Point : (1, -2) is created.Point : (2, -1) is created.Point : (0, 0) is created.Point : (0, 0)Point : (0, 0) is created.Point : (0, 0) is created.Line : (0, 0) to (0, 0) is created.Point : (0, 0) is created.Point : (0, 0) is created.Line : (0, 0) to (0, 0) is created.Point : (0, 0) is created.Point : (0, 0) is created.Line : (0, 0) to (0, 0) is created.Point : (0, 0) is created.Point : (0, 0) is created.Line : (0, 0) to (0, 0) is created.Line : (0, 0) to (1, 1)Line : (1, 1) to (2, 3)Line : (2, 3) to (4, 5)Line : (0, 1) to (1, 0)Point : (1, -2) is copied.Point : (2, -1) is copied.Line : (1, -2) to (2, -1) is created.Point : (1, -2) is copied.Point : (0, 0) is copied.Line : (1, -2) to (0, 0) is created.Point : (2, -1) is copied.Point : (0, 0) is copied.Line : (2, -1) to (0, 0) is created.Point : (1, -2) is copied.Point : (2, -1) is copied.Line : (1, -2) to (2, -1) is copied.Line : (1, -2) to (2, -1)Line : (1, -2) to (2, -1)Line : (2, -1) to (0, 0)Line : (0, 0) to (2, -1)Line : (0, 0) to (2, -1) is erased.Point : (2, -1) is erased.Point : (0, 0) is erased.Line : (2, -1) to (0, 0) is erased.Point : (0, 0) is erased.Point : (2, -1) is erased.Line : (1, -2) to (2, -1) is erased.Point : (2, -1) is erased.Point : (1, -2) is erased.Line : (1, -2) to (2, -1) is erased.Point : (2, -1) is erased.Point : (1, -2) is erased.Line : (0, 1) to (1, 0) is erased.Point : (1, 0) is erased.Point : (0, 1) is erased.Line : (2, 3) to (4, 5) is erased.Point : (4, 5) is erased.Point : (2, 3) is erased.Line : (1, 1) to (2, 3) is erased.Point : (2, 3) is erased.Point : (1, 1) is erased.Line : (0, 0) to (1, 1) is erased.Point : (1, 1) is erased.Point : (0, 0) is erased.Point : (0, 0) is erased.Point : (2, -1) is erased.Point : (1, -2) is erased.

HINT

Append Code

[ Submit][ Status][ Web Board]
#include <iostream>
#include <iomanip>
using namespace std;
class Point
{
private :
     double x,y;
     friend class Line;
public :
     Point():x (0) ,y (0)  {cout<< "Point : (" <<x<< ", " <<y<< ") is created." <<endl; }
     Point( double x_ , double y_ ):x(x_),y(y_){  cout << "Point : (" <<x<< ", " <<y<< ") is created." << endl; }
    //  void setvalue(double xx,double yy)
    // {
    //     x = xx;
   //      y = yy;
   //  }
     void show(){cout<< "Point : (" <<x<< ", " <<y<< ")" <<endl;}
     Point( const Point &p){
     x = p.x;y = p.y; cout << "Point : (" <<x<< ", " <<y<< ") is copied." << endl;  }
     //double getx(){return x;}
     //double gety(){return y ;}
     //void setx(int xx) {x = xx;}
     //void sety(int yy) {y = yy;}
     ~Point(){ cout << "Point : (" <<x<< ", " <<y<< ") is erased." << endl;  }
};
class Line
{
private :
     Point x1_,y1_;
     friend class Point;
public :
     Line():x1_(0,0),y1_(0,0)
     {
           cout<< "Line : (" <<x1_.x<< ", " <<x1_.y<< ") to (" <<y1_.x<< ", " <<y1_.y<< ") is created." <<endl;
     }
     Line( double xx1, double yy1, double xx2, double yy2):x1_(xx1,yy1),y1_(xx2,yy2)
     {
         cout<< "Line : (" <<x1_.x<< ", " <<x1_.y<< ") to (" <<y1_.x<< ", " <<y1_.y<< ") is created." <<endl;
     }
     Line(Point &q1,Point &q2):x1_(q1),y1_(q2)
     {
         cout<< "Line : (" <<x1_.x<< ", " <<x1_.y<< ") to (" <<y1_.x<< ", " <<y1_.y<< ") is created." <<endl;
     }
      Line( const Line &t):x1_(t.x1_),y1_(t.y1_){
             cout << "Line : (" << x1_.x << ", " << x1_.y << ") to (" << y1_.x << ", " << y1_.y << ") is copied." << endl;
         }
     void show()
     {
         cout<< "Line : (" <<x1_.x<< ", " <<x1_.y<< ") to (" <<y1_.x<< ", " <<y1_.y<< ")" <<endl;
     }
     ~Line()
     {
         cout<< "Line : (" <<x1_.x<< ", " <<x1_.y<< ") to (" <<y1_.x<< ", " <<y1_.y<< ") is erased." <<endl;
     }
     void SetLine( double a, double b, double c, double d)
     {
         x1_.x = a;
         x1_.y = b;
         y1_.x = c;
         y1_.y = d;
     }
     void readLine()
     {
         double x1 ,x2 ,y1 ,y2;
         char c;
         cin >> x1 >> c >> y1 >> x2 >> c >> y2;
         SetLine(x1,y1,x2,y2);
     }
     Line &setLine( const Point& t1, const Point& t2)
     {
         x1_ = t1;
         y1_ = t2;
         return * this ;
     }
     Line &setLine( const Line& t)
     {
         x1_ = t.x1_;
         y1_ = t.y1_;
         return * this ;
     }
};
 
int main()
{
     int num, i;
     Point p(1, -2), q(2, -1), t;
     t.show();
     std::cin>>num;
     Line line[num];
     for (i = 0; i < num; i++)
     {
         line[i].readLine();
         line[i].show();
     }
     Line l1(p, q), l2(p,t), l3(q,t), l4(l1);
     l1.show();
     l2.setLine(l1).show();
     l3.show();
     l4.setLine(t,q).show();
}

和直线(综合型题目) (1)创建C#控制台应用程序L4_1。 (2)在程序中新建一个CzPoint,为其定义两个double型的私有字段成员x和y,分别表示的横坐标和纵坐标。 (3)为CzPoint定义两个公有属性X、Y,分别用于封装对字段x和y的读写访问。 (4)定义CzPoint的带参数构造函数,在其中对字段x和y进行初始化。 (5)为CzPoint定义公有方法Move,用于按指定的水平距离和垂直距离移动坐标。 (6)对CzPoint进行相等和不相等操作符重载。两个坐标相等,是指它们的横坐标和纵坐标都相等。 (7)在程序主方法中创建两个坐标对象,判断它们是否相等;而后将第一个坐标移动到第二个坐标上,再判断它们是否相等。 (8)在程序中再新建一个直线CzLine,为其定义两个double型的字段成员a 和b,分别表示直线的斜率和截距;再定义字段封装属性A和B,但它们都是只读的。 (9)为CzLine定义两个构造函数,一个根据斜率和截距来创建直线对象,另一个则根据两个CzPoint对象来构造直线对象(直线穿过这两个)。后一个的参考源代码如下(因涉及数学公式,故给出代码): public CzLine(CzPoint p1,CzPoint p2) { this.a=(p2.Y-p1.Y)/(p2.X-p1.X); this.b=p1.Y-this.a*p1.X; } (10)为CzLine定义公有方法Move,但它只用于平移直线,而不改变直线的斜率(即平移后的直线与原来的直线平行)。再为其定义公有方法Contains,用于判断某是否在该直线上。 (11)似的,为CzLine重载相等和不相等操作符。 (12)最后在程序主方法中采用不同的方式创建直线对象,并编译运行程序,测试它们的使用效果。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值