一个难题

题记

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin. this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise. 

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30) 

Output

For each test case, you should output the a^b's last digit number. 

Sample Input

7 66
8 800

Sample Output

9
6

***************************************************************************************************************************

这个题简洁来说就是求a的b次方的最后一位数,因为是求最后一位数,所以可以通过取余10的方法来简化运算

同时还可以通过二次化简来使算法简洁化,也就是通过将b/2的方法来对式子简化,如果b是奇数,就将c与a相乘,得到新的c,之后将b除2,a自乘,以此构建一个循环,来求出最终结果的个位数c


	a %=10;
	while(b>0){
		if(b%2==1)
			c=c*a%10;
		b /=2;
		a = a*a %10;
	}
	return c;
综合代码:


#include <stdio.h>
int fei(int a,int b){
	int c=1;
	a %=10;
	while(b>0){
		if(b%2==1)
			c=c*a%10;
		b /=2;
		a = a*a %10;
	}
	return c;
} 
int main()
{
	int a,b,c;
	while(~scanf("%d %d",&a,&b)){
		c = fei(a,b);
		printf("%d\n",c);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值