N! 大数定理

1218: N!

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 158   Solved: 24
[ Submit][ Status][ Web Board]

Description

Given an integer N(0 ≤ N ≤ 3000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1
2
3

Sample Output

1
2

6

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int a[10000],h=1,jws=0;
		memset(a,0,sizeof(a));
		a[0]=1;
		for(int i=1;i<=n;i++)
		{
			for(int j=0;j<h;j++)
			{
				int rex=a[j]*i+jws;
				jws=rex/10;
				a[j]=rex%10;
			}
			while(jws)
			{
				a[h++]=jws%10;
				jws/=10;
			}
		}
		for(int i=h-1;i>=0;i--)	
		{
			printf("%d",a[i]);
		}
		printf("\n");
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值