A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 432378 Accepted Submission(s): 84194


 

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

 

Sample Input

 

2

1 2

112233445566778899 998877665544332211

 

Sample Output

 

Case 1:

1 + 2 = 3

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

#include<iostream>
#include<string>
#include<string.h>
using namespace std;
int main(void) {
    char a[1000],b[1000];
    int a_int[1001],b_int[1001];
    int t,a_len,b_len,max_len;//t判断case次数
    cin>>t;
    while(t--) {
        cin>>a>>b;    //计算两个数组实际长度
        a_len=strlen(a);
        b_len=strlen(b);
        int tmp=0;    //将字符数组值反向存入整形数组,输入的数字的个位数在a_int[0]
        for(int j=a_len-1; j>=0; j--) {
            a_int[tmp++]=a[j]-'0';
        }
        tmp=0;
        for(int k=b_len-1; k>=0; k--) {
            b_int[tmp++]=b[k]-'0';
        }    ///将两数组用0填充使其位数相等,他们填充后的位数是最大位数加1,而不是只到最大位数,这是为了后面计算方便
        if(a_len>b_len) {
            for(int j=b_len; j<=a_len; j++) {
                b_int[j]=0;
            }
            a_int[a_len]=0;
        } else if(a_len<b_len) {
            for(int j=a_len; j<=b_len; j++) {
                a_int[j]=0;
            }
            b_int[b_len]=0;
        } else { //当两个位数一样时,都留出1位给进位
            a_int[a_len]=0;
            b_int[b_len]=0;
        }    //求和,最后保存到a_int里面
        max_len=(a_len>=b_len)?a_len:b_len;
        //重点 
        for(int j=0; j<=max_len; j++) {
            a_int[j]+=b_int[j];
            if(a_int[j]>=10) {
                a_int[j]-=10;
                a_int[j+1]+=1;
            }
        }
        cout<<"Case "<<i<<":"<<endl;
        cout<<a<<" "<<"+"<<" "<<b<<" "<<"="<<" ";
        //判断最高位是否有进位,有就输出
        if(a_int[max_len]==0) {
            for(int j=max_len-1; j>=0; j--)
                cout<<a_int[j];
        } else {
            for(int j=max_len; j>=0; j--)
                cout<<a_int[j];
        }
        if(i!=t)//结尾不能输出换行 
            cout<<endl<<endl;
        else
            cout<<endl;

    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值