Decrease (Contestant ver.)(AtCoder-2661)

Problem Description

We have a sequence of length N consisting of non-negative integers. Consider performing the following operation on this sequence until the largest element in this sequence becomes N−1 or smaller.

Determine the largest element in the sequence (if there is more than one, choose one). Decrease the value of this element by N, and increase each of the other elements by 1.
It can be proved that the largest element in the sequence becomes N−1 or smaller after a finite number of operations.

You are given an integer K. Find an integer sequence ai such that the number of times we will perform the above operation is exactly K. It can be shown that there is always such a sequence under the constraints on input and output in this problem.

Constraints

  • 0≤K≤50×1016

Input

Input is given from Standard Input in the following format:

K

Output

Print a solution in the following format:

N
a1 a2 ... aN
Here, 2≤N≤50 and 0≤ai≤1016+1000 must hold.

Example

Sample Input 1

0

Sample Output 1

4
3 3 3 3

Sample Input 2

1

Sample Output 2

3
1 0 3

Sample Input 3

2

Sample Output 3

2
2 2
The operation will be performed twice: [2, 2] -> [0, 3] -> [1, 1].

Sample Input 4

3

Sample Output 4

7
27 0 0 0 0 0 0

Sample Input 5

1234567894848

Sample Output 5

10
1000 193 256 777 0 1 1192 1234567891011 48 425

题意:有一个长度为 n 的序列,现在要对其进行 k 次操作,每次操作将序列中最大的元素减小 n,将其他元素增加 1,在有限次操作后,序列中的最大元素要小于等于 n-1,求这个序列的长度 n 与每个元素的值

思路:

由于 n 最大到 50,因此直接设序列长度为 50 然后进行逆推,即初始数组就是 [0,49],每次选择一个最小的数 +50,其他数 -1

那么当经过 50 次操作后,就变成了 [1,50],可以发现有:((k-1/50)+1)-1

此时还剩下 k%50 次操作,首先考虑 k%50=0 的情况,由于此时是 n 的倍数,那么次数循环次数算的是向下完整的循环,即会使得全部数+1;而当 k%50>0 时,此时就要先暴力进行 k%50 次操作,再考虑 k%50=0 的情况

Source Program

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#include<bitset>
#define EPS 1e-9
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
const int MOD = 1E9+7;
const int N = 200000+5;
const int dx[] = {-1,1,0,0,-1,-1,1,1};
const int dy[] = {0,0,-1,1,-1,1,-1,1};
using namespace std;
LL a[N];
int main() {
    LL k;
    scanf("%lld",&k);
    if(k==0){
        printf("2\n");
        printf("1 1\n");
    }
    else{
        for(int i=1;i<=50;i++)
            a[i]=i-1;

        LL temp=(k-1)/50+1;
        for(int i=1;i<=50;i++)
            a[i]+=(temp-1);

        int times=k%50;
        if(times==0)
            for(int i=1;i<=50;i++)
                a[i]++;

        for(int i=1;i<=times;i++){
            for(int j=1;j<=50;j++){
                if(i==j)
                    a[i]+=50;
                else
                    a[j]--;
            }
        }

        printf("%d\n",50);
        for(int i = 1;i<=50;i++)
            printf("%lld ",a[i]);
        printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值