Constructing Roads

Written by Robert_Wang in Southwest University of Science And Technology.

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9149    Accepted Submission(s): 3383

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 
We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
 
Sample Output
179

Tips:很多人wa的原因是此题要用多组输入!!!我弄了很久才发现的。

1.最小生成树问题。Prim算法

dist[i] 代表某边到最小生成树中所有的边的和最小。虽然保存的是一条边,但是在最小生成树中,所有的边的和都是最小的、

2.核心代码if (dist[w] && map[v][w] < dist[w]) dist[w] = map[v][w];w是v的邻接点。

3.初始化问题,假设从0开始生成,就应该将dist[i] = map[0][i];如果某一点被收录进MST,就赋值为-1,不能赋值为0,因为边的值也可能为0

#include<iostream>
using namespace std;
#define MAXV 202
#define INF 99999999
int n, map[MAXV][MAXV];
int dist[MAXV];//记录到i的最小距离(MST)
int vis[MAXV];//记录到i的最小距离(MST)
int FindMin()
{
	int MinV = INF, v = -1;
	int i;
	for (i = 0; i < n; i++)
	{
		if (dist[i]!=-1 && dist[i] < MinV) {
			MinV = dist[i];
			v = i;
		}
	}
	return v;
}
int Prim()
{
	int v,w,MinCost = 0, i, j;
	for (i = 0; i < n; i++) dist[i] = map[0][i];
	dist[0] = -1;
	while (1)
	{
		v = FindMin();
		if (v == -1) break;
		MinCost += dist[v];
		dist[v] = -1;
		for (w = 0; w < n; w++)
		{
			if (dist[w] && map[v][w] < dist[w]) dist[w] = map[v][w];
		}
	}
	return MinCost;
}
int main()
{
	int q,i,j,k;
	while (cin >> n)
	{
		fill(dist, dist + n, INF);
		for (i = 0; i < n; i++)
		{
			for (j = 0; j < n; j++)
			{
				cin >> map[i][j];
			}
		}
		cin >> q;
		int a, b;
		for (i = 0; i < q; i++)
		{
			cin >> a >> b;
			a--; b--;
			map[a][b] = 0;
			map[b][a] = 0;
		}
		cout << Prim() << endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

江湖无为

感谢你们的鼓励

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值