Constructing Roads(最短路径)

描述:

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.


输入:

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.


输出:

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.


样例输入:

3
0 990 692
990 0 179
692 179 0
1
1 2


样例输出:

179



题目大意:

先输入一个正整数n代表n个城镇,接下去是n*n的一个二维数组第i行第j列的数代表城镇i和j之间的距离。再输入一个正整数x,接下去x行每行有两个正整数x1,y1.代表城镇x1与y1之间已经有道路连接。求为使得全部城镇连通最短还有造多少长的路。



/*
此题的方法与Frogger那道相同*/ 
#include<stdio.h>
#include<string.h>
#include<limits.h>
int map[105][105],dis,mark[105],asd[105],n,t;
void prim()													//prim算法 
{
	for(int i=1;i<=n;i++)
	asd[i]=map[1][i];
	mark[1]=1;
	int p,k;
	for(int i=1;i<=n;i++)
	{
		p=INT_MAX;
		for(int j=1;j<=n;j++)
		{
			if(mark[j]==0&&p>asd[j])
			{
				k=j;														//记录下此时所在的位置 
				p=asd[j];
			}
		}
		if(p==INT_MAX)														//如果相等说明此时的道路已经全部连接 
		break;
		mark[k]=1;
		dis+=asd[k];
		for(int j=1;j<=n;j++)
		{
			if(mark[j]==0&&asd[j]>map[k][j])
			{
				asd[j]=map[k][j];
			}
		}
	}
}
int main()
{
	int a,b;
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
		{
			scanf("%d",&map[i][j]);										 
		}
	}
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d %d",&a,&b);											//将已经建有道路的两个城市x,y的map[x][y]置为0 
		map[a][b]=0;
		map[b][a]=0;
	}
	dis=0;
	memset(mark,0,sizeof(mark));										//定义一个标志变量判断城市是否被访问过 
	prim();
	printf("%d\n",dis);
	return 0;
} 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值