1020 Tree Traversals (25 分)(已知后序和中序求层序)

1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

 题目:

            已知后序和中序求层序

思路:

           注意建树时候的参数即可,观察1020与1086题的建树的写法  中序的参数类都是 inl到p1-1  p1+1到inr,注意总结 

#include<iostream>
#include<queue>
#include<vector>
using namespace std;
const int maxn=10000;
int n;
struct Node
{
	int data;
	int lchild,rchild;
}node[maxn];
int post[maxn],in[maxn];
int build(int postl,int postr,int inl,int inr)
{
	if(inr<inl)
	return 0;
	int root=post[postr];
	int p1,p2;
	p1=inl;
	while(in[p1]!=root)
	p1++;
	p2=p1-inl;//左子树个数
	node[root].lchild=build(postl,postl+p2-1,inl,p1-1);
	node[root].rchild=build(postl+p2,postr-1,p1+1,inr); 
	return root;
} 
vector<int>ans;
void bfs(int root)
{
	queue<int>q;
	q.push(root);
	int num=0;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		ans.push_back(u);
		if(node[u].lchild)
		q.push(node[u].lchild);
		if(node[u].rchild)
		q.push(node[u].rchild);
	}
}
int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	scanf("%d",&post[i]);
	for(int i=0;i<n;i++)
	scanf("%d",&in[i]);
	int root=build(0,n-1,0,n-1);
	//cout<<root<<endl;
	bfs(root); 
	for(int i=0;i<ans.size();i++)
	{
		printf("%d",ans[i]);
		if(i<ans.size()-1)
		printf(" ");
	}	
}

                                                                           

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值