【2011】中序后序求层序

27 篇文章 2 订阅
5 篇文章 0 订阅

输入树的后序和中序排列,输出树的层次遍历

Sample Input:

7

2 3 1 5 7 6 4

1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2
#include<iostream>
#include<queue>
using namespace std;
const int maxn = 110;
int post[maxn], in[maxn];
struct node {
	int data;
	struct node *left;
	struct node* right;
};
node *build_tree(int inL, int inR, int postL, int postR) {
	if (postL > postR)
		return NULL;
	node* root = new node;
	root->data = post[postR];
	int i;
	for (i = inL; i <= inR; i++) {
		if (in[i] == post[postR]) {
			break;
		}
	}
	int numk = i - inL;
	root->left = build_tree(inL, i-1, postL, postL +numk-1);
	root->right = build_tree(i + 1, inR, postL +numk, postR - 1);
	return root;
}
void layerorder(node* root) {
	queue<node*> q;
	q.push(root);
	while (!q.empty()) {
		node *now = q.front();
		cout << now->data;
		q.pop();
		if (now->left != NULL)
			q.push(now->left);
		if (now->right != NULL)
			q.push(now->right);
	}
}
int main() {
	int n;
	cin >> n;
	for (int i = 0; i < n; i++)
		cin >> post[i];
	for (int i = 0; i < n; i++)
		cin >> in[i];
	node* root=build_tree(0, n - 1, 0, n - 1);
	layerorder(root);
	system("pause");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值