bfs hrbust1012

Catch That Cow

Time Limit: 2000 MS

Memory Limit: 65536 K

Total Submit: 2234(607 users)

Total Accepted: 891(546 users)

Rating:

Special Judge: No

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

For each test case :

Line 1: Two space-separated integers: N and K

Process to the end of file.

Output

For each test case :

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17
100 100

Sample Output

4
0


题意:人在N,奶牛在K,一次能是x->x+1/x->x-1/x->2*x  ,求 最少的移动步数
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
int m,n;
int vis[200005];
int bfs(int a)
{
	queue<int>s;
	s.push(a);
		vis[a] = 1;
	while(!s.empty())
	{
		int a1 = s.front();
		s.pop();
		if( a1 == n )
		{
			return vis[a1]-1;
		}
		for(int i = 0; i < 3; i++)
		{
			int a2;
			if(i == 0)
				a2 = a1 + 1;
			if(i == 1)
				a2 = a1 - 1;
			if(i == 2)
				a2 = 2*a1;
			if(a2 >= 0&&a2 < 200000&&!vis[a2]) 
			{
				vis[a2] = vis[a1]+1;
				s.push(a2);	
			}
		} 
	}
}
int main()
{
	while(~scanf("%d%d",&m,&n))
	{
		memset(vis,0,sizeof(vis));
		printf("%d\n",bfs(m));
	}
	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值