HRBUST 1012 Catch That Cow

HRBUST 1012 Catch That Cow

链接:http://acm.hrbust.edu.cn/index.php?m=ProblemSet&a=showProblem&problem_id=1012

题目:

Catch That Cow

Time Limit: 2000 MSMemory Limit: 65536 KB

64-bit integer IO format: %lld , %llu Java class name: Main

[Submit][Status][Discuss]

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

For each test case :

Line 1: Two space-separated integers: N and K

Process to the end of file.

Output

For each test case :

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17
100 100

Sample Output

4
0

题意:给你两个数a,b。能进行x+1,x-1,x*2三种操作,问你从a到b最少要变化多少次。

思路:bfs


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
const int MAX = 100000;
int step1[3] = {0,1,-1};
int step2[3] = {2,1,1};
int num[MAX+9];
int number;
int zhuan;

int bfs(int start,int over)
{

    queue<int> que;
    que.push(start);
    num[start] = 0;
    while(!que.empty()){
        number = que.front();
        que.pop();
        for(int i = 0;i < 3;i++){
            zhuan = number*step2[i]+step1[i];//三种变化
            if(zhuan <= MAX && zhuan >= 0 && num[zhuan] == 0 && zhuan != start){
                que.push(zhuan);
                num[zhuan] = num[number]+1;
            }
        }
    }
    return num[over];
}

int main()
{
    int start,over;
    while(scanf("%d%d",&start,&over) != EOF){
        memset(num,0,sizeof(num));
        if(start == over)
            printf("0\n");
        else
            printf("%d\n",bfs(start,over));
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值