A - 2^x mod n = 1

Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1. 

Input

One positive integer on each line, the value of n. 

Output

If the minimum x exists, print a line with 2^x mod n = 1. 

Print 2^? mod n = 1 otherwise. 

You should replace x and n with specific numbers. 

Sample Input

2
5

Sample Output

2^? mod 2 = 1
2^4 mod 5 = 1

题意:就是给你一个数n,让你找到一个数X,使得2^x mod n==1;

这个题就是分类讨论,当n==1 || n为偶数时,一定不可能存在这样的n。

当x为不为1的奇数时,一定存在。然后就暴力找就行了。

#include <iostream>
#include <string>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <cmath>
#include <list>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
int poww(int a,int b,int c){
    int ans=1;
    a=a%c;
    while(b!=0){
        if(b&1) ans=(ans*a)%c;
        b>>=1;
        a=(a*a)%c;
    }
    return ans;
}

int main()
{	int n;
	while(~scanf("%d",&n))
	{
		if(n%2==0)
		{printf("2^? mod %d = 1\n",n);
		}
		else if(n==1)
		{
			printf("2^? mod 1 = 1\n");
		}
		else{	int i=2;
			while(1)
			{
				if(poww(2,i,n)%n==1)
				{
					printf("2^%d mod %d = 1\n",i,n);
					break;
				}
				i++;
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值