1052 Linked List Sorting (25分)

题目

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N ( ≤ 1 0 5 ) N(\le10^5) N(105) and an address of the head node, where N N N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N N N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [ − 1 0 5 , 1 0 5 ] [-10^5, 10^5] [105,105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N N N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题目大意

给出一个链表,对链表按key值升序排列。

思路

按照题目意思,迅速写完代码,提交两个测试点不过,又反复思考测试点,来来回回想了很久,就没发现有过不了的测试点,无奈只好百度,才恍然大悟,这道题着实是有点坑,说说他的坑点在哪里吧:

  1. 并不是所有题目给定的节点都一定会在以给定的开始结点为首元结点的链表中,实际上题目只要求输出以给定的开始结点为首元结点的链表,其余节点不做考虑.
  2. 这个链表中有可能一个结点也没有,即题目给出的开始节点为-1.

仔细想想,题目是坑了点,但还是自己做题经验不足吧,知道了坑点,题目也就很好解决了.

技巧

这个题并不需要真实的模拟链表排序,只需要把节点信息存储在vector中,直接用sort()排序,再修改next即可.

代码

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

struct Node{
    int address, data, next;
};

bool cmp(Node a, Node b){
    return a.data < b.data;
}

int main(){
    int data[100000], next[100000], n, head;
    scanf("%d%d", &n, &head);
    for(int i=0, t; i<n; i++){
        scanf("%d", &t);
        scanf("%d", data+t);
        scanf("%d", next+t);
    }
    int p = head;
    vector<Node> ans;
    while(p != -1){
        Node node;
        node.address = p;
        node.data = data[p];
        node.next = -1;
        ans.push_back(node);
        p = next[p];
    }
    if(ans.size() == 0){
        printf("0 -1\n");
        return 0;
    }
    sort(ans.begin(), ans.end(), cmp);
    for(int i=0; i<ans.size()-1; i++)
        ans[i].next = ans[i+1].address;
    printf("%d %05d\n", ans.size(), ans[0].address);
    for(int i=0; i<ans.size(); i++){
        printf("%05d %d ", ans[i].address, ans[i].data);
        if(ans[i].next != -1)
            printf("%05d\n", ans[i].next);
        else
            printf("-1\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
请参考我给出的代码框架,实现对EMPLOYEE结构体为数据的双向链表的排序算法,要求按照按employeeId升序排列 typedef struct linkNode { void* data; //使用空指针使得NODE适配多种数据结构 struct linkNode* preNode; struct linkNode* nextNode; }LINKED_NODE; /*Define the struct of double linked list.*/ typedef struct { LINKED_NODE* head; LINKED_NODE* tail; size_t size; }DOUBLE_LINK_LIST; typedef struct { int employeeId; char name[20]; char ipAddress[30]; char seatNumber[20]; char group[10]; } EMPLOYEE; DOUBLE_LINK_LIST* createDoubleLinkedList() { DOUBLE_LINK_LIST* newList = (DOUBLE_LINK_LIST*)malloc(sizeof(DOUBLE_LINK_LIST)); newList->head = NULL; newList->tail = NULL; newList->size = 0; return newList; } void destroyDoubleLinkedList(DOUBLE_LINK_LIST* list) {} /*Add a new node before the head.*/ void insertHead(DOUBLE_LINK_LIST* list, void* data) // void执政适配其他data类型? {} /*Add a new node after tail.*/ void insertTail(DOUBLE_LINK_LIST* list, void* data) // 如何适配其他data类型? {} /*Insert a new node.*/ void insertNode(DOUBLE_LINK_LIST* list, void* data,int index) // 如何适配其他data类型? {} void deleteHead(DOUBLE_LINK_LIST* list) {} void deleteTail(DOUBLE_LINK_LIST* list) {} void deleteNode(DOUBLE_LINK_LIST* list, int index) {} LINKED_NODE* getNode(DOUBLE_LINK_LIST* list, int index) {} /* 遍历链表,对每个节点执行指定操作*/ void traverseList(DOUBLE_LINK_LIST* list, void (*callback)(void*)) { LINKED_NODE* currentNode = list->head; while (currentNode != NULL) { callback(currentNode->data); currentNode = currentNode->nextNode; } } void printEmployee(void* data) {}
最新发布
07-25
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值